Get the Original: Because Steve Says So T-Shirt
Your one stop Mac spot

Warning: file() [function.file]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /homepages/30/d186991128/htdocs/MacBlogzStaging/wp-content/themes/macblogz/header.php on line 101

Warning: file(http://download.finance.yahoo.com/d/quotes.csv?s=AAPL&f=sl1d1t1c1ohgv&e=.csv) [function.file]: failed to open stream: Success in /homepages/30/d186991128/htdocs/MacBlogzStaging/wp-content/themes/macblogz/header.php on line 101
AAPL: 0.00 ( . )

Blog

First Generation iPod touch to Support VoIP Through Firmware 2.2

The latest firmware 2.2 release for users of the first generation iPod touch has now enabled the use of VoIP without requiring any extensive modding.

With Firmware 2.2, Apple has made a concerted effort to upgrade the recording aptitude of its touch devices, namely the ability to record from third party mics connected through its dock port. iPodNN notes that, many of these recording devices have been on the market since the standard iPod 5.5 generation, yet were previously not supported by the first-gen iPod touch. The error messages would previously appear when using such devices in the touch are now said to have vanished, which has effectively opened the doors to allowing VoIP functionality.

Italian site, Macitynet.it, has successfully shown that the new firmware does allow for error free use of third party mics such as, the Macally iVoice III and iVoice Pro. Through the use of the VoIP application, NimBuzz, the test crew were able to make a successful voice call.

“So we got a free NimBuzz account and we set up our skype account: as magic the Green Phone icon was show as solid and we could press the virtual call button. Our friend Massimo Senna’s voice came out loud from Macally iVoice Pro speaker and he could hear us with the usual noisy feedback effect. It works!”

After doing a bit more research, they had discovered that while actual recording is possible, there are currently no applications in the App Store that recognize third party dock-connected recording devices. Hopefully we will see a few of these apps surface in the near future, and with some luck a few will actually be accepted to the App Store.

Comments [12]

12 Comments to “First Generation iPod touch to Support VoIP Through Firmware 2.2”

bbb @ November 26th, 2008 at 1:38 pm
 Add karma Subtract karma  +0

I myself would like to see a double line calculator (scientific) in the app store

Reply

Gertjan @ December 9th, 2008 at 5:40 am
 Add karma Subtract karma  +2

If you turn the iPod while the calculator is on, It will change to a scientific calculator.

Reply

Myron @ December 7th, 2008 at 9:04 pm
 Add karma Subtract karma  +0

Fring will work with 2.2 and got excellent audio notes results with “Notes2Self” from the app store. Great sound. Using Touch 1G with Macally ivoiceIII. Never thought this would be possible.

Reply

adam @ December 21st, 2008 at 7:10 am
 Add karma Subtract karma  +0

if I upgrade to 2.2 on my 1g iPod touch buy a macaly ivoice pro, download nimbuzz I will be able to make a skype call. Is that correct?

Reply

philippe @ June 25th, 2009 at 8:50 am
 Add karma Subtract karma  +0

that is correct
it works wonderfully well
FRING is ok. but, sound is better with a direct SIP application like SIPphone or Weephone
you can use skype app too

anyone nows the impact of FW 3.0 on ipod touch 1G microphone dock input ?

Reply

Rob @ July 7th, 2009 at 12:30 pm
 Add karma Subtract karma  +0

Yes, rumor is that FW 3.0 kills the ipod touch first generation microphone dock. You either need to downgrade your firmware or wait for Macally to release a new microphone, which may not happen… :(

Reply

philippe @ July 17th, 2009 at 9:01 am
 Add karma Subtract karma  +0

hello to all,
to rob : thanks for your input ; where does the rumor come from ? in some forum a guy explained it is fine for him in 3.0
ph.

Reply

Rob @ July 25th, 2009 at 4:10 pm
 Add karma Subtract karma  +0

The rumor came from the Skype forums, apparently 3.0 killed the microphone compatibility in the first gen touch.

I found the forum you mentioned, so I asked the guy which microphone he has and to confirm that it works..

http://discussions.apple.com/thread.jspa?messageID=9882843#9882843

Fingers crossed, I’d love to use skype with my 1st gen..

Reply

philippe @ July 28th, 2009 at 7:17 am
 Add karma Subtract karma  +0

according to “jsun” FW 3.0 works fine with macally ivoiceIII :)

and if it is ok with ivoiceIII it should be ok with ivoicepro too, it is the same one with a speaker included

(btw you can activate / deactivate the speaker depending on when you plug in the earphone)

Reply

Jon @ September 13th, 2009 at 5:40 pm
 Add karma Subtract karma  +0

It stopped working for me at OS3.1. Sometimes I can connect it and it works but 80% of the time I get and “unsupported device” nag pop up.

Reply

philippe @ October 6th, 2009 at 2:02 am
 Add karma Subtract karma  +0

thanks Jon for this update. can you confirm it worked fine when you where using 3.0 ?
(if you have been using 3.0 !)
rgds,
ph.

Reply

philippe @ October 9th, 2009 at 5:56 am
 Add karma Subtract karma  +0

all,
any news on impact of FW 3.1.2 ?

Reply